Accelerated Master's in Software Engineering

California State University, Fullerton

Admission Requirements

To enter the Accelerated Master’s in Software Engineering, you must have completed the following requirements. If you have any questions, please contact us and a staff member will get back to you soon.

Minimum Requirements for Admission

  • Bachelor’s Degree in Computer Science, or a related major along with equivalent professional experience
  • Minimum GPA of 2.5 for your last 60 semester units
  • Prerequisites course: CPSC 362 Foundations of Software Engineering (or equal professional experience)
  • TOEFL (international applicants only): a minimum score of 550 (paper) or 80 (iBT) or 6.5 Academic IELTS or 58 PTE.

    GRE not required

How to Apply

Applications open in the late summer and the program starts in the spring. You can view application instructions and dates, or start your application, on our Apply page. If you would like to receive application updates, join our email list below.


AMSE director Dr. Bin Cong

“If you are a talented software engineer, you will have opportunities. Everyone will be looking for you.”

- Bin Cong, CSUF Professor and AMSE Program Director

Read Interview

What’s your next step?

Learn about our program fees or join the AMSE email list. By joining the list you will also receive program and application updates.

Fees

What's your next step - Fees

Our program is a fast and affordable way to advance in the software engineering field. Learn more about program costs on our Fees page.

Fees

back to top

This site is maintained by Extension and International Programs.

 Last Published 9/11/19

To report problems or comments with this site, please contact eipcommunications@fullerton.edu.
© California State University, Fullerton. All Rights Reserved.

Web Accessibility

CSUF is committed to ensuring equal accessibility to our users. Let us know about any accessibility problems you encounter using this website.
We'll do our best to improve things and get you the information you need.

Version_4.0.99.f